Recently we released Beta version of PHP SDK 2.1. Among other improvements it has support of PHP version 7. We plan to release one more version before GA, which will provide support for new features of the upcoming server release. Until then, enjoy PHP7 support:

Also the package (and windows binary versions) can be downloaded from our site at SDK Downloads.

NOTE: You MUST have libcouchbase 2.5+ installed (http://packages.couchbase.com/clients/c/index.html) prior to the installation of the php extension.

If you encounter any issues, please post directly to the Couchbase Communities site at http://www.couchbase.com/communities/php. Additionally, bugs can be reported directly through our issues tracker available here: https://www.couchbase.com/issues/browse/PCBC

Stay tuned.

Posted by Sergey Avseyev, SDK Engineer, Couchbase

Leave a reply