Ruby Gem

February 11, 2013

Using Couchbase Ruby Gem with EventMachine

As you may have noticed the new couchbase ruby gem has been released recently. The release 1.2.2 is mostly a maintenance release with several bug fixes, but yet you can try one new experimental feature: integration with EventMachine library. This post will give you a quick intro about how to start using Couchbase Server with your applications based on the EventMachine asynchronous model.

The EventMachine integration is only (currently) accessible on UNIX-like systems (like Linux, Solaris, BSD).  Because it uses fibers, it also requires MRI ruby version 1.9 or later.

Read more »